Date: 
Wednesday, Feb 16th, 2022
Advisory ID: 
BACKDROP-SA-CORE-2022-001
Security risk: 
Moderately Critical
Vulnerability: 
Improper input validation
Versions affected: 
  • Backdrop Core 1.21.x versions prior to 1.21.2
  • Backdrop Core 1.20.x versions prior to 1.20.5

Backdrop versions 1.19 and prior do not receive security coverage.

Description: 

Backdrop core's Form API has a vulnerability where certain forms in contributed or custom modules may be vulnerable to improper input validation. This could allow an attacker to inject disallowed values or overwrite data. Affected forms are uncommon, but in certain cases an attacker could alter critical or sensitive data.

Solution: 

Upgrade your site to the most recent version of Backdrop core. Download available on the Backdrop CMS 1.21.2 release page. See the update instructions, if needed.

Reported By: 
Fixed By: 
Coordinated By: 

Security email list

Backdrop maintains a security mailing list. Whenever a security release comes out, an email will be sent to everyone subscribed to that list, announcing the new release. Please follow the steps below to join the Security email list.

  • Log in to backdropcms.org
  • Edit your profile
  • Scroll down to the "Email notifications" section
  • Check the box labeled "Receive BackdropCMS.org security announcements for core and contrib projects"