Date: 
Wednesday, Jul 21st, 2021
Security risk: 
Critical
Advisory ID: 
BACKDROP-SA-CORE-2021-004
Vulnerability: 
Third Party Libraries
Versions affected: 
  • Backdrop Core 1.19.x versions prior to 1.19.2
  • Backdrop Core 1.18.x versions prior to 1.18.6

Backdrop versions 1.17 and prior do not receive security coverage.

Description: 

The Backdrop project uses the pear Archive_Tar library, which has released a security update that impacts Backdrop.

The vulnerability is mitigated by the fact that Backdrop core's use of the Archive_Tar library is not vulnerable, as it does not permit symlinks. Backdrop also does not use Archive_Tar in normal operation of the site, but maintains it for compatibility with contrib modules and custom code.

Exploitation may be possible if contrib or custom code uses the library to extract tar archives (for example .tar, .tar.gz, .bz2, or .tlz) which come from a potentially untrusted source.

Solution: 

Upgrade your site to the most recent version of Backdrop core. Download available on the Backdrop CMS 1.19.2 release page. See the update instructions, if needed.

Reported By: 
Fixed By: 
Coordinated By: 

Security email list

Backdrop maintains a security mailing list. Whenever a security release comes out, an email will be sent to everyone subscribed to that list, announcing the new release. Please follow the steps below to join the Security email list.

  • Log in to backdropcms.org
  • Edit your profile
  • Scroll down to the "Email notifications" section
  • Check the box labeled "Receive BackdropCMS.org security announcements for core and contrib projects"