Date: 
Wednesday, Jul 3rd, 2024
Advisory ID: 
BACKDROP-SA-CORE-2024-001
Security risk: 
Moderately Critical
Vulnerability: 
Cross Site Scripting
Versions affected: 
  • Backdrop Core 1.28.x versions prior to 1.28.2
  • Backdrop Core 1.27.x versions prior to 1.27.3

Backdrop versions 1.26 and prior do not receive security coverage.

Description: 

Backdrop CMS doesn't sufficiently sanitize field labels before they are displayed in certain places.

This vulnerability is mitigated by the fact that an attacker must have a role with the permission "administer fields".

 

A CVE has been requested, and this page will be updated as soon as an official number has been issued.

Solution: 

Upgrade your site to the most recent version of Backdrop core. Download available on the Backdrop CMS 1.28.2 release page. See the update instructions, if needed.

Reported By: 
Fixed By: 
Coordinated By: 

Security email list

Backdrop maintains a security mailing list. Whenever a security release comes out, an email will be sent to everyone subscribed to that list, announcing the new release. Please follow the steps below to join the Security email list.

  1. Log in to backdropcms.org
  2. Edit your profile
  3. Switch to the "Subscriptions" tab
  4. Check the box labeled "Security updates"
  5. Save the form