Date: 
Wednesday, Apr 21st, 2021
Security risk: 
Critical
Advisory ID: 
BACKDROP-SA-CORE-2021-002
Vulnerability: 
Cross Site Scripting
Versions affected: 
  • Backdrop Core 1.18.x versions prior to 1.18.3
  • Backdrop Core 1.17.x versions prior to 1.17.7

Backdrop versions 1.16 and prior do not receive security coverage.

Description: 

Backdrop core's sanitization API fails to properly filter cross-site scripting under certain circumstances. 

Not all sites and users are affected, but configuration changes to prevent the exploit might be impractical and will vary between sites. Therefore, we recommend all sites update to this release as soon as possible.

Solution: 

Upgrade your site to the most recent version of Backdrop core. Download available on the Backdrop CMS 1.18.3 release page. See the update instructions, if needed.

Reported By: 
Fixed By: 

Security email list

Backdrop maintains a security mailing list. Whenever a security release comes out, an email will be sent to everyone subscribed to that list, announcing the new release. Please follow the steps below to join the Security email list.

  • Log in to backdropcms.org
  • Edit your profile
  • Scroll down to the "Email notifications" section
  • Check the box labeled "Receive BackdropCMS.org security announcements for core and contrib projects"