Date: 
Thursday, Mar 21st, 2019
Moderately Critical
Advisory ID: 
BACKDROP-SA-CORE-2019-008
Vulnerability: 
Cross Site Scripting
Versions affected: 
  • Backdrop Core 1.12.x versions prior to 1.12.5
  • Backdrop Core 1.11.x versions prior to 1.11.8

Under certain circumstances the File module/subsystem allows a malicious user to upload a file that can trigger a cross-site scripting (XSS) vulnerability.

Solution: 

Upgrade your site to the most recent version of Backdrop core. Download available on the Backdrop CMS 1.12.5 release page.  See the update instructions, if needed.

Reported By: 
Fixed By: 
Coordinated By: 

Security email list

Backdrop maintains a security mailing list. Whenever a security release comes out, an email will be sent to everyone subscribed to that list, announcing the new release. Please follow the steps below to join the Security email list.

  • Log in to backdropcms.org
  • Edit your profile
  • Scroll down to the "Email notifications" section
  • Check the box labeled "Receive BackdropCMS.org security announcements for core and contrib projects"